Share ilmu yuk!,

Mei 11, 2009

Menggunakan rails versi lama, pada komputer dengan rails versi baru

Filed under: Ruby Programming — ugifractal @ 2:07 am

Saya pernah mendapatkan kasus seperti ini. Komputer saya sudah terinstall Rails versi 2.0.2, nah disisi lain saya membutuhkan environment untuk bekerja di rails versi 1.2.5. Saya pernah terpikir untuk menginstall dulu rails versi 1.2.5 kemudian melakukan freeze, atau mungkin mengextract beberapa gem yang berjalan di 1.2.5 untuk dijadikan plugin.

Tapi ternyata ada solusi lain yang lebih gampang. Untuk memfreeze rails versi 1.2.5, kita dapat lakukan dengan perintah berikut

rake rails:freeze:edge TAG=rel_1-2-5

Selesai deh, dan bisa maen lagi di rails versi 1.2.5 dengan spesific project.

Tinggalkan sebuah Komentar »

Belum ada komentar.

RSS feed for comments on this post. TrackBack URI

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

Buat situs web atau blog gratis di WordPress.com.

%d blogger menyukai ini: